Back to overview
Resolved

Database provider outage

Jun 30, 2026 at 5:00pm UTC
Affected services
meritfirst.us
Platform-wide issues
Candidate-facing issues
Employer-facing issues

Resolved
Jun 30, 2026 at 5:11pm UTC

Supabase has reported the issue resolved and we have seen a decrease in database connection errors. We will continue to monitor on our end as well.

Created
Jun 30, 2026 at 5:00pm UTC

Our database provider, Supabase, is currently experiencing a major outage and as a result our app is severely degrated.
You can follow their status page here: https://status.supabase.com/, but we will share updates here as well.

We apologize for this inconvenience.