Back to overview
Maintenance
Scheduled Database Maintenance
Jun 3, 2026 at 2:30am UTC
–
Jun 3, 2026 at 3:00am UTC
Affected services
meritfirst.us
Candidate-facing issues
Employer-facing issues
Resolved
Jun 3, 2026 at 3:00am UTC
Maintenance ended
Affected services
Created
Jun 3, 2026 at 2:30am UTC
We will be performing scheduled database maintenance on Tuesday, June 2 from 9:30 PM to 10:00 PM CDT (approximately 30 minutes). During this window, the app will be unavailable and candidates will not be able to start or take assessments. We recommend planning around this time. Thank you for your patience.
Affected services